All HTTP status codes The IANA registry, updated 2025-09-15.
Code Name Reference 100 Continue RFC 9110, section 15.2.1 101 Switching Protocols RFC 9110, section 15.2.2 102 Processing RFC 2518 103 Early Hints RFC 8297 104 Upload Resumption Supported (TEMPORARY - registered 2024-11-13, extension registered 2025-09-15, expires 2026-11-13) draft-ietf-httpbis-resumable-upload-05 105-199 Unassigned 200 OK RFC 9110, section 15.3.1 201 Created RFC 9110, section 15.3.2 202 Accepted RFC 9110, section 15.3.3 203 Non-Authoritative Information RFC 9110, section 15.3.4 204 No Content RFC 9110, section 15.3.5 205 Reset Content RFC 9110, section 15.3.6 206 Partial Content RFC 9110, section 15.3.7 207 Multi-Status RFC 4918 208 Already Reported RFC 5842 209-225 Unassigned 226 IM Used RFC 3229 227-299 Unassigned 300 Multiple Choices RFC 9110, section 15.4.1 301 Moved Permanently RFC 9110, section 15.4.2 302 Found RFC 9110, section 15.4.3 303 See Other RFC 9110, section 15.4.4 304 Not Modified RFC 9110, section 15.4.5 305 Use Proxy RFC 9110, section 15.4.6 306 (Unused) RFC 9110, section 15.4.7 307 Temporary Redirect RFC 9110, section 15.4.8 308 Permanent Redirect RFC 9110, section 15.4.9 309-399 Unassigned 400 Bad Request RFC 9110, section 15.5.1 401 Unauthorized RFC 9110, section 15.5.2 402 Payment Required RFC 9110, section 15.5.3 403 Forbidden RFC 9110, section 15.5.4 404 Not Found RFC 9110, section 15.5.5 405 Method Not Allowed RFC 9110, section 15.5.6 406 Not Acceptable RFC 9110, section 15.5.7 407 Proxy Authentication Required RFC 9110, section 15.5.8 408 Request Timeout RFC 9110, section 15.5.9 409 Conflict RFC 9110, section 15.5.10 410 Gone RFC 9110, section 15.5.11 411 Length Required RFC 9110, section 15.5.12 412 Precondition Failed RFC 9110, section 15.5.13 413 Content Too Large RFC 9110, section 15.5.14 414 URI Too Long RFC 9110, section 15.5.15 415 Unsupported Media Type RFC 9110, section 15.5.16 416 Range Not Satisfiable RFC 9110, section 15.5.17 417 Expectation Failed RFC 9110, section 15.5.18 418 (Unused) RFC 9110, section 15.5.19 419-420 Unassigned 421 Misdirected Request RFC 9110, section 15.5.20 422 Unprocessable Content RFC 9110, section 15.5.21 423 Locked RFC 4918 424 Failed Dependency RFC 4918 425 Too Early RFC 8470 426 Upgrade Required RFC 9110, section 15.5.22 427 Unassigned 428 Precondition Required RFC 6585 429 Too Many Requests RFC 6585 430 Unassigned 431 Request Header Fields Too Large RFC 6585 432-450 Unassigned 451 Unavailable For Legal Reasons RFC 7725 452-499 Unassigned 500 Internal Server Error RFC 9110, section 15.6.1 501 Not Implemented RFC 9110, section 15.6.2 502 Bad Gateway RFC 9110, section 15.6.3 503 Service Unavailable RFC 9110, section 15.6.4 504 Gateway Timeout RFC 9110, section 15.6.5 505 HTTP Version Not Supported RFC 9110, section 15.6.6 506 Variant Also Negotiates RFC 2295 507 Insufficient Storage RFC 4918 508 Loop Detected RFC 5842 509 Unassigned 510 Not Extended (OBSOLETED) RFC 2774]; [Status change of HTTP experiments to Historic 511 Network Authentication Required RFC 6585 512-599 Unassigned
About this table The table is a copy of the IANA HTTP Status Code Registry as read on 14 November 2026. Rows with a range, such as 104-199, are numbers that are not assigned. 418 is listed as unused in RFC 9110. Codes with a link have a page here with a real response. Codes that CDNs and servers add on their own, such as 520 or 499, are not in the registry.
This is an independent guide. It is not connected with the IETF, IANA, any browser maker or any company named here. Meanings were checked against the RFC texts on 14 November 2026. Responses shown were recorded on 14 November 2026 from a small test server on the author's own computer.